S2 - Users unable to load BI Module
Incident Report for Eptura Asset
Postmortem

Eptura Asset Detailed Root Cause Analysis (RCA) – Severity 2 Event May 2, 2024 

 We are profoundly grateful for your continued support and loyalty. We value your feedback and appreciate your patience as we worked to resolve this incident. 

Description: 

On May 2nd, 2024, 6:02 AM MST we received reports that customers were not able to print. This occurred shortly after a standard maintenance release. Our team attempted a server configuration change in an effort to improve overall BI module performance. The configuration change was rolled back due to the errors encountered.

Type of Event: 

S2 event - Service disruption. BI module was down. 

Services\Modules Impacted: 

BI Module 

Remediation: 

Once DevOps realized the new configuration was not working, they immediately initiated the roll back. 

Timeline:

5-2-24 3:00 AM - BI configuration upgrade started during standard maintenance window 

5-2-24 5:35 AM – End of Maintenance window 

5-2-24 5:51 AM – Roll back initiated. 

5-2-24 6:02 AM – First client reported that they were not able to print BI reports. 

5-2-24 6:12 AM - Fire alarm initiated by the support team. 

5-2-24 8:11 AM – DevOps completed the roll back and customers confirmed the module was back online 

5-2-24 8:11 AM - Issue resolved, All Clear 

Total Duration of Event: 

2 hours 36 minutes 

Root Cause Analysis:

The BI temp folder needed to be cleaned and the service restarted after the roll back procedure.  

Preventative Action: 

Efforts to test and deploy configuration changes will be performed in a controlled environment before releasing to production in the future.

Posted May 06, 2024 - 14:21 UTC

Resolved
This incident has been resolved.
Posted May 02, 2024 - 16:56 UTC
Identified
The issue with BI has been identified and a fix is being implemented. We will post another update at 12:00pm CST.
Posted May 02, 2024 - 13:06 UTC
Update
We are currently investigating an issue with our BI module. Our Engineering team is currently investigating to determine the cause of the disruption. Next update will be posted at 11:30 CST
Posted May 02, 2024 - 12:41 UTC
Investigating
We are currently investigating an issue with ManagerPlus. We will update you when we have more information.
Posted May 02, 2024 - 12:13 UTC
This incident affected: Business Intelligence.